icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.xzlrgc.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

山东11选5 www.631365.cc-彩票开奖怎么看| www.01522.cc-彩吧代理申请| www.568491.com-新浪爱彩是什么意思| www.088228.com-澳客体彩足球强哥| www.327711.com-百度彩票中奖查询| www.463325.com-机选福彩排列7| www.580522.com-江苏福彩快-| www.782775.com-中华彩票官方预测网| www.934709.com-快乐三分彩官网| www.cai1686.com中国福彩快3江苏| www.539413.com-哪一类彩票销量最好| www.633607.com-可以网络购彩吗| www.721739.com-网上彩票破解| www.796416.com-彩16官方版-| www.90pi.com-福彩3d小军黑苍蝇| www.7010.cc-极速3d彩票1分钟| www.835018.com-民生炫彩油画额度| www.212593.com-注册就送彩金时时彩| www.343499.com-大连体育彩票招聘| www.493754.com-体彩排列三专家荐胆| www.606235.com-福利彩票买号| www.766737.com-玩黑彩输钱了报案| www.938899.com-中国竞彩网网址| 500彩票www.51515m.com| www.033129.com-体彩四川金7乐开奖| www.2765.biz-中彩票的图-| www.9893.in-万森彩票平台线路| www.76248.com-温州福彩申请| www.068679.com-彩票1分快3资料| www.50455.com-彩票网站怎么搭建| www.038499.com-好彩票怎么下载不了| www.139554.com-中超足彩app| www.233387.com-快三投注网-| 大赢家彩票www.658056.com| www.855934.com-时时彩规律口诀05| www.976284.com-重庆结婚彩礼| www.no4.cc-河南快三跑马一定牛| www.ua40.com-体育彩票术语| www.673579.com-祠堂彩绘图案| www.866237.com-手机上买彩票网站| www.82zf.com-599彩票安全么| www.525780.com-24小时极速时时彩| www.682489.com-中央彩票公益金项目| www.915091.com-竞彩专家推荐分析| www.cp6715.com-江苏快三真能赚钱吗| www.32qc.com-长沙福利彩票官网| www.2260.vip-大中华彩票是骗人的| www.01238.cc-最新送白菜彩金网站| www.029870.com-567彩票app-| www.89929.com-七彩影视违法吗| www.123898.com-买彩票团队-| www.213068.com-彩票计划苹果手机版| www.290491.com-3d彩经网走势新版| www.365850.cc-福彩快三中奖奖金| www.459575.com-的的跟单体彩软件| www.007552.com-体育彩票中奖号| www.823845.com-双色球福彩开奖结果| www.941612.com-合买彩票话术| www.999677.com-长沙彩票店转让| www.hy68.com-福彩体彩基本走势图| www.124099.com-安徽体彩app| www.781207.com-31体彩走势图| www.861637.com-福彩快3怎么玩| www.465687.com-体彩八卦图-| www.554011.com-彩蛋图片画法小黄人| www.645270.com-彩霸王心论坛| www.768962.com-苹果足球彩票app| www.cp6116.com-福彩网软件下载| www.cai7211.com甘肃快三推荐预测| www.xx27.com-977彩票是哪的| www.fy75.com-快三预测软件破解版| www.r42.biz-皇都彩票是安全的吗| www.93pz.com-彩色相机普及| www.3019.biz-彩世家手机版| www.8764.top-彩预测客户端| www.579234.com-众投彩官网下载| www.716215.com-彩票计划程序| www.5396.biz-河北体彩快三玩法| www.593522.com-杭州7彩阳光大酒店| www.rh26.com-极速快三挂-| www.345613.com-福利彩世界是真的吗| www.by57.cc-广西快三走势带连线| www.zc28.com-福彩体彩网址大全| www.64va.com-福彩3d猜三同| www.2412.tv-江西省多乐彩| www.120539.com-怎么下载中国彩票| www.225820.com-快乐彩任选三| www.319044.com-江西快三开奖爱彩乐| www.8097.vip-优信彩票投注| www.76267.com-足彩开奖最新消息| www.593080.com-七彩彩票真的假的| www.v27.org-登录九州彩票网站| www.71nq.com-买彩票的诗-| www.1999.pro-12.cc彩票-| www.02383.com-中彩吧论坛-| www.61285.cc-购彩v是什么东西| www.6218.cm-今天乐彩网摘| www.193562.com-大乐购彩票是什么| www.1709.cn-中一等奖彩票图片| www.981138.com-牛牛彩票网骗局揭秘| www.657435.com-时时彩代理被抓判刑| www.028629.com-五行预测彩票的方法| www.873164.com-贵州彩票app| www.fv07.com-北京快三数据遗漏| www.161359.com-福彩实业有限公司| www.bm.cc-快3彩票倍投技巧| 幸运彩票www.631799.com| www.wf96.com-时时彩后三计划| www.cai8895.com河北省快三未出号码| www.652708.com-彩28彩票平台| www.637049.com-彩虹六号历届冠军| www.29ry.com-竞剩足球彩客网| www.509512.com-鑫鑫彩票合买| www.780839.com-排列五奇偶走势图彩| www.881591.com-百胜9b彩票网站| www.790109.com-虚拟彩票摇奖机| www.905006.com-有卖快三挣到钱的没| www.972647.com-彩铅画图片简单好看| www.cp823.com-福彩快3下载苹果| www.351144.com-竞彩赢钱会不会被黑| www.467597.com-几点以后不能买彩票| www.555923.com-078彩票经销商| www.623719.com-广州鸣彩公司诈骗案| www.686205.com-彩票500计划群| www.755316.com-中国彩票3d图迷| www.817858.com-足彩19034盈亏| www.875333.com-亿元彩票的故事| www.928528.com-福彩3d出号规律| www.972643.com-彩铅意境画-| 快彩www.81678y.com| www.jt88.com-重庆时时彩一定牛| www.050704.com-黑彩代理能赚多少钱| www.126094.com-彩运彩票app下载| www.195825.com-快三时时彩票| www.959003.com-231彩票-| 大赢家彩票网www.178281.com| www.43199.cc-中彩网11选5合买| www.09br.com-28cc天下彩| www.771284.com-彩虹六号战队查询| www.509268.com-快三彩票是否合法| www.47248.com-体彩销售点-| www.846123.com-足彩必发交易量指数| www.939592.com-手机福彩违法| www.993769.com-中国足彩网第一彩| www.bt68.com-彩票之家网站| www.13cd.com-福彩3d彩票谜语| www.79iq.com-百彩网综合资料| www.4688.in-竞彩贴吧-| www.713951.com-彩票上可以写名字吗| www.9775.loan-休闲快三九寨红叶| www.289698.com-大乐透杀号彩宝贝| www.62176.com-双彩球预测专家| www.764122.com-为什么禁止网彩| www.hf17.com-购彩平台哪个最好用| www.108957.com-七彩鱼全品种| www.982149.com-新彩网i新彩网| www.wh8.cc-新加坡快三开奖助手| www.sl03.com-网上买彩票报警电话| www.62bn.com-福彩网上投注app| www.742626.com-好运彩彩票网下载| www.872081.com-贵阳市福利彩票中心| www.00ek.com-新加坡十分彩是什么| www.68wz.com-区块链彩票股票| www.025834.com-彩票套利方法大全|